Unable to reach other locations on MPLS

########### PE1 #############

ip vrf nestle
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
ip vrf pepsi
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
!
multilink bundle-name authenticated

interface Loopback0
ip address 10.0.0.3 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.9.6 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding nestle
ip address 10.0.1.1 255.255.255.252
ip ospf 2 area 0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf forwarding pepsi
ip address 10.0.1.5 255.255.255.252
ip ospf 3 area 0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 2 vrf nestle
router-id 10.0.1.1
log-adjacency-changes
redistribute bgp 65000 subnets
!
router ospf 3 vrf pepsi
router-id 10.0.1.5
log-adjacency-changes
redistribute bgp 65000 subnets
!
router ospf 1
mpls ldp autoconfig
log-adjacency-changes
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.4 remote-as 65000
neighbor 10.0.0.4 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.4 activate
neighbor 10.0.0.4 send-community extended
exit-address-family
!
address-family ipv4 vrf pepsi
redistribute ospf 3 vrf pepsi match internal external 1 external 2
no synchronization
exit-address-family
!
address-family ipv4 vrf nestle
redistribute ospf 2 vrf nestle match internal external 1 external 2
no synchronization

########## PE2 ####################

PE2#sh running-config brief
Building configuration…

Current configuration : 2001 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf nestle
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
ip vrf pepsi
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
!
multilink bundle-name authenticated

interface Loopback0
ip address 10.0.0.4 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.9.10 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding pepsi
ip address 10.0.2.5 255.255.255.252
ip ospf 3 area 0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf forwarding nestle
ip address 10.1.2.1 255.255.255.252
ip ospf 2 area 0
duplex auto
speed auto
!
router ospf 2 vrf nestle
router-id 10.0.2.1
log-adjacency-changes
redistribute bgp 65000 subnets
!
router ospf 3 vrf pepsi
router-id 10.0.2.5
log-adjacency-changes
redistribute bgp 65000 subnets
!
router ospf 1
mpls ldp autoconfig
log-adjacency-changes
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.3 remote-as 65000
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
exit-address-family
!
address-family ipv4 vrf pepsi
redistribute ospf 3 vrf pepsi match internal external 1 external 2
no synchronization
exit-address-family
!
address-family ipv4 vrf nestle
redistribute ospf 2 vrf nestle match internal external 1 external 2
no synchronization
exit-address-family

CE-Nestle-HQ

VE-Netsle#sh running-config brief
Building configuration…

Current configuration : 859 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VE-Netsle
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!

!
interface Loopback0
ip address 172.16.1.1 255.255.255.255
ip ospf 2 area 0
!
interface FastEthernet0/0
ip address 10.0.1.2 255.255.255.252
ip ospf 2 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
router ospf 2
router-id 10.0.1.2
log-adjacency-changes
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4

CE-Nestle-BR

E-Pepsi#sh running-config bri
CE-Pepsi#sh running-config brief
Building configuration…

Current configuration : 825 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE-Pepsi
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.2.6 255.255.255.252
ip ospf 3 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 3
router-id 10.0.2.6
log-adjacency-changes
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-planea
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4

could you please share the MPLS forwarding table, routing table, and vrf table from all 6 router

Configuration looks ok use the command

Routes are coming from one location to another in customer routers?

From which device you are pinging?