Unable to declare switch port trunk in layer 2 switch

Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode. this error message i am getting. can anyone help why i am getting this error. and how can i resolve it?

Bro this is L2 Switch… no no need to give that command.

This is because the interface needs to have a specific encapsulation type, such as 802.1Q, to support trunking.
To fix this, the interface needs to get configured with the command switchport trunk encapsulation dot1q. This will enable the interface to be configured to trunk mode.
encapsulation still L2
depending on the software the command may be a bit different.
Please ensure you do not have a mix in modes (trunk and access) in the same interface.

1 Like

its working now… after rebooting the switch. thanks

1 Like