NAT - Not working (Need Assistance)

I know it’s simple but yes i admit i am stuck with it and it’s not working

Nat doesn’t Work in my Lab, though it has worked previously but i am not able to do it now.
Sharing all the config below, can someone please help me indicating my mistake and help me fix it.
VPC can ping all the IP’s hop by hop till Router Public IP, but NAT isn’t happening
When i do “sh ip nat translation” i see nothing.
All the config has been shared below.

Edge Router
Router#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is to network

S* [254/0] via
S [1/0] via is variably subnetted, 2 subnets, 2 masks
C is directly connected, FastEthernet0/0
L is directly connected, FastEthernet0/0 is variably subnetted, 2 subnets, 2 masks
C is directly connected, FastEthernet1/0
L is directly connected, FastEthernet1/0

interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex full
interface FastEthernet1/0
ip address
ip nat inside
duplex full

ip nat inside source list 1 interface FastEthernet0/0 overload

ip route
access-list 1 permit log
access-list 1 permit log

interface Ethernet0/0
no switchport
ip address
interface Ethernet0/1
switchport access vlan 10
switchport mode access

interface Vlan10
ip address

ip route

Ignore this GUYS, i was able to fix this myself. There was some kind of glitch with the Image used. Worked after refreshing the device.